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About This Book

This guide explains how to install, build, and execute Windows Embedded CE 6.0 OS images for
the SDK board, using the Freescale .MX28 SDK Windows CE Multimedia Framework Software
Development Kit (SDK).

Audience

This document is intended for software, hardware, and system engineers who are planning to use
the product and for anyone who wants to understand more about the product.

Organization

This document contains the following chapters.
Chapter 1 Explains how to install/uninstall the SDK.
Chapter 2 Explains how to build Windows CE OS images using the BSP.

Chapter 3 Explains how to test the multimedia components that you install.

Conventions

This document uses the following conventions:

Courier Is used to identify commands, explicit command parameters, code
examples, expressions, data types, and directives.

Italic Is used for emphasis, to identify new terms, and for replaceable command
parameters.

References

The following documents were referenced to build this document.

1. Windows Embedded CE 6.0 BSP for 1.MX28 EVK User’s Guide

i.MX28 SDK Windows Multimedia Framework User's Guide, Rev 2010.08

Freescale Semiconductor v



Chapter 1
Installation

The Freescale Multimedia Framework Software Development Kit (SDK) is a collection of
binary, code, and support files that you can use to create Windows CE OS images for the . MX28
EVK board. The SDK is distributed as a single archive EXE (.exe) file.

There are two steps to perform for the installation: first, install the .MX28 EVK Board Support
Package (BSP), and then install the SDK into the Windows CE source code tree and the Platform
Builder development environment.

1.1 Installing the BSP

To install the BSP, follow the steps in Chapter 1 of the Windows Embedded CE 6.0 BSP for
i.MX28 EVK User's Guide.
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1.2 Installing the SDK

To install the SDK, use these steps:

NOTE

Before installing the SDK, save any modified files and close
the sample workspace, because the Installer will modify the
file of the sample workspace project.

1. Run the installation execution package.

The Setup Wizard screen is displayed (Figure 1-1).

# Freescale Multimedia SDK for iMX28-E¥YK Advan -10] x|

Waelcome to the Freescale
Multimedia SDK for iMX28-EVEK
Advanced Version 05.06.00 Setup

This wizard will guide wou through the installation of
Freescale Mulkimedia SDK For iME238-EYE Advanced Yersion
05.06,00,

It is recommended that vou close all other applications
before starting Setup. This will make it possible to update
relevant syskem files without having to reboat your
compuker,

lick, Mext to continue.,

Zancel |

Figure 1-1 Setup Screen

2. Click Next.

The Choose Components screen is displayed (Figure 1-2).
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& Freescale Multimedia SDK for iMX28-EYK Advanced ¥ersion 0 - 0] x|

Choose Components (

Choose which Features of Freescale Multimedia SOE Far iMX28-EVE &dvanced Version Q‘j
05.06.00 wou want ko inskall, .

heck the components wou wank to install and uncheck the components wou don't wank to
inskall, Click Mext o continue,

Select the tvpe of install:

B_uskorm
Or, select tthe Dpti':.'r'lflt Install Multimedia Component
components wou wish to =
inskall: Patch BSP

Space required: 12,5M6

< Back I Mext = I Zancel

Figure 1-2 Choose Components

3. Click Next.

The installation location screen is displayed.
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§ Freescale Multimedia SDK for iMX28-EYK Advanced Yersi - 0] x|

Choose Install Location C_

Chonose the Falder in which to install Freescale Multimedia SDE Far ilMX25-Evk; 4}
Advanced Yersion 05,0600, )

Setup will install Freescale Multimedia SDE For iME28-EVE Advanced Yersion 05.06.00 in the
Following Falder, To install in a different Folder, click Browse and select another Folder, Click
Install bo stark the installation,

Destination Folder

W IMCEEODPLATEORMYM:28-EVELSRC Mulkinedia Browse. .. |

Space required: 12,5M6
Space available: 22.2G6

< Back I Install I Zancel

Figure 1-3 Selecting the Installation Location

4. Under Destination Folder, set the path of the destination folder for the SDK installation.
By default, the multimedia framework SDK will be installed in the following path:

“$ (_WINCEROOT) \Platform\<platform_name>\src\Multimedia"

where:
— $(_WINCEROOT) is the path of your Windows CE root folder - WINCE600

— <platform_name> is the name of the SDK platform BSP directory — iMX28-EVK for
1.MX28 EVK Windows Embedded CE 6.0 BSP

5. Continue with the installation wizard until the installation is complete.

6. In the final installation window (Figure 1-4) you can select whether to do a clean build for
the Windows CE OS Image automatically.

— If Make Run-time Image (NK.bin) is selected, the entire image build procedure,
which includes the CSP build, BSP build, and SYSGEN, will be implemented
automatically.

— During the automatic build, all of the FSL developed multimedia components are
included in the OS Image by default.
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§ Freescale Multimedia SDK for iMX28-EYK Advanc o ] S

Completing the Freescale
Multimedia SDK for iMX28-EVK
Advanced Version 05.06.00 Setup

Freescale Mulkimedia SDF For iME28-EYE Advanced Yersion
05.06.00 has been installed on vour computer,

Click. Finish ko clase this wizard,

™ Make Run-time Image(ME.bin}

< Bach: I Einish I Zance|

Figure 1-4 Setup Complete Screen
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1.2.1  Checking the Installation

This section explains how to ensure that the multimedia framework SDK was installed
successfully. The installer copies the Multimedia SDK folder into the BSP code tree:

¢ For Windows Embedded CE 6.0, the folder is copied to
\WINCE60O\platform\<platform>\src

1.2.1.1 Check the SDK folder in the BSP code tree

The SDK code tree architecture is shown in Figure 1-5. The table that follows describes the
folder contents.

=1 123 Multimedia
|20 API_include
= |2 binao0
H 15 libarm®
= ) components
H I3 audio
[+ ) parser
=l 1) core_libs
[+ |2} codec
F ) parser
# [ ) docs
;3rmx

Figure 1-5 Multimedia SDK Code Tree Screen

Folder Contents

API|_include This folder contains the global header files of multimedia DirectShow DMO and Filters.

components This folder, with its audio, video, parser, and image subfolders, contains the DirectShow
DMO and Filters source code of multimedia components.

core_libs This folder contains header files and library binaries of multimedia components.

Docs This folder contains APl document, Datasheet and release notes of all of the
components.

Misc This folder contains the *.reg and *.bib file required by platform builder.

bin600 Thdese folders contain DLL and EXE binaries, which are built by the components’ source
code.

1.2.1.2 Check the BSP modification performed by the installer

The SDK installer modifies the BSP to support the Freescale multimedia components.
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To check the BSP modifications, use these steps:

1. In the bsp_cfg.h file under s (_WINCEROOT) \platform\<platform>\src\inc\, check
that the line BSP_VID_MEM_CACHE_WRITETHROUGH has been defined as
TRUE, as follows:

#define BSP_VID_MEM CACHE_WRITETHROUGH TRUE

2. In the platform.reg file under $ (_ WINCEROOT) \platform\<platform>\files\, check
the following line was added:

#include "$ (_TARGETPLATROOT) \src\Multimedia\misc\fslmm mx28.reg"

3. In the platform.bib file under s (_WINCEROOT) \platform\<platform>\files\, check
that the following line was added:

#include "$(_TARGETPLATROOT)\src\Multimedia\misc\fslmm_mx28.bib"

1.2.1.3 Check the workspace modified by the installer

The SDK installer modifies the Platform Builder’s workspace to support the Freescale
multimedia components.

To check the workspace, use these steps:

1. In Platform Builder IDE, select menu Project -> iMX28-EVK-Mobility Properties ->

Configuration Properties -> Environment, check the variables were added, as indicated

— Added — variable TGTARM has been set to arm9
— Added — variable BSP_ WATERMARK has been set to 1

2. In Catalog items View, check that the following DirectShow system components of the

OS Build were added or removed, as indicated:

— Added - all components in Core OS > CEBASE > Graphics and Multimedia
Technologies -> Media -> DirectShow

— Added - the component Core OS > CEBASE > Graphics and Multimedia
Technologies > Media > Media Formats > MPEG-1 Parser/Splitter

— Added - the component Core OS > CEBASE > Graphics and Multimedia
Technologies > Media > Media Format > AVI Filter

— Added - the component Core OS > CEBASE > Graphics and Multimedia

Technologies > Media > Audio Codecs and Renderers > Wave/AIFF/au/snd File

Parser

1.2.2 Removing an Existing Installed SDK

This section explains how to remove an installation of the SDK from the Windows CE source
code tree and Platform Builder development environment.
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NOTE

Before uninstalling the SDK, save any modified files that you
want to keep to a protected location, because uninstalling the
SDK will remove all files that were populated by the Installer.

To remove an SDK installation, use these steps:

1. Close Platform Builder.

2. Click Start > Settings > Control Panel > Add or remove Programs.
The Add or Remove Programs dialog is displayed.

3. Remove the SDK.

4. Manually remove the remaining SDK files and directories.

$ (_WINCEROOT)\Platform\<platform name>\src\Multimedia

i.MX28 SDK Windows Multimedia Framework User's Guide, Rev 2010.08
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Chapter 2
Building OS Images

After completing the SDK installation, you can use the sample workspace to build a Windows
CE OS Image based on the installed SDK. You may add or remove image build components.

2.1  Working with Multimedia Components

The multimedia components are located in the Windows Catalog. You import the catalog, and
can then add the components to the OS Image build.

2.1.1  Importing the Windows Embedded CE 6.0 Catalog

For Windows Embedded CE 6.0, the multimedia catalog is automatically imported when the
sample workspace is opened.

To view the catalog, use these steps:

1. Click View > Other Windows > Catalog Items View.

The Catalog Items View dialog is displayed (Figure 2-1).
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Catalog Itkems Yiew |
=] Filker ~ <gearch= -
....................... —

SR 1:25-EVK
=1 BSP
&L Core 05
--1_] Device Drivers
EH_] Third Party
#- B5P
=2 MultiMedia
E|1_j Freescale i.MX28 EVE MMSDE
=00 Audio
~[v] a8 Decoder
~[¥] MP3 Decoder
~[v] WA Decoder
=1 Parser
-[m] FsL Source Filker
MP4 Parser
=1 Video
-[m] Generic Video Decoder Filker b
-[v] Hz64 Decoder
—[] MPEG4 Decoder hd

L:"EJSDMHDI'I Explorer l@ Zatalog Ikems YWiew

Figure 2-1 Multimedia SDK Catalog View
2. To view the multimedia components, open Third Party > Multimedia > Freescale

i.MX28 EVK MMSDK.

2.1.2 Add/Remove components from Catalog

To add/remove components from the catalog, use these steps:

1. Click View > Other Windows > Catalog Items View.

2. To view the multimedia components, open Third Party > Multimedia > Freescale
i.MX28 EVK MMSDK.

3. To add/remove a multimedia component, just select/unselect the associated check box.

2.2 Building OS Images

This section explains how to build Windows CE OS image included multimedia components in
the sample workspace.
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2.2.1 Building an Image in Platform Builder

For instructions for building OS images using Platform Builder, see the Windows Embedded CE
6.0 BSP for i MX28 EVK User's Guide.

2.2.2 Building an Image using the Command Line

The SDK installation provides the £s1_mmfmwk_build.bat script, which builds the OS image.
You can run this script during the last installation step or in the command line after installation.

To run the script in the command line, follow these steps:

1. Open the command console on your PC.
2. Goto the $ (_WINCEROOT) \platform\<platform>\src\Multimedia\ directory.

3. Run fsl_mmfmwk_build.bat.

2.3 Building Multimedia Components in sample Workspace

This section explains how to build/rebuild installed multimedia components after the SDK
upgrading or the modification on multimedia components’ source code.

2.3.1  Building all components simultaneously

To build all of the installed components at once, use these steps:

1. Go to the Solution Explorer View, and then open the Multimedia project in the folder
Platform > iMX28-EVK > SRC.

2. Right-click on the Multimedia project, and then select Rebuild.

This builds all DLL and EXE binaries in the bin600 directories under the Multimedia
folder in the BSP code tree.

2.3.2 Building individual components

To build individual components, use these steps:

1. In the project window, open the individual component subproject in the Multimedia
project

2. Right-click an individual component’s sub-project, and then select Rebuild
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This builds the DLL and EXE binaries in the bin600 directories under the Multimedia
folder in the BSP code tree.
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Chapter 3
Using the Test Procedures

This chapter explains how to test the Freescale multimedia components in the Windows CE OS.
The image was built as described in chapter 2.

3.1  Audio Decoder Test

To perform this test, use the Windows CE Media Player to playback the audio files.

3.2 Video Decoder Test

To perform this test, use the Windows CE Media Player to playback the video files.
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Patches and Fixes

Upon installation, Freescale patches are automatically installed. However, you may also install
the patches manually, if you prefer to confirm that they are installed.

A.1 Video Memory Cache Policy
Applies to: Windows Embedded CE 6.0

About: The Freescale video decoder requires that the cache policy of the video memory (IPU
buffer) be write-through. Performance issues will occur with non-cacheable or write-back
memory.

Action: Before you build the BSP, double check the following:

1. Open the bsp_cfg.h file in the following directory
\WINCE60O0\PLATFORM\<platform>\src\inc\

2. In the file, BSP_VID_MEM_CACHE_WRITETHROUGH should be TRUE, as shown:
#define BSP_VID_MEM_CACHE_WRITETHROUGH TRUE
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