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What is Eclipse?

►A Java development environment

• Widely regarded as the Java development environment

►An IDE framework

• Eclipse + JDT = Java IDE

• Eclipse + CDT = C/C++ IDE

• Eclipse + PHP = PHP IDE

• Eclipse + JDT + CDT + PHP = Java

►A Tools Framework

• Focused on developing a universal platform of frameworks and exemplary tools

►An Open Source Project and Community

• All Eclipse projects are open-source and available for free download

• Hundreds of plug-ins are provided by commercial companies, organizations, 
and individuals
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What is Eclipse?

►An ecosystem

• Focused on nurturing the eco-system to complement and enhance the Eclipse 
Platform

• Many members, including major Java, Linux and Embedded vendors

• Dozens of open source projects

• Millions of downloads

►A Foundation

• Independent not-for-profit foundation formed in 2004

• Created to manage and direct the ongoing development of the Eclipse open 
source software project 

• Responsible for providing IT infrastructure required by development teams
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Eclipse Foundation Members

► Strategic Members – Actuate, brox, ca, Cloudsmith, Genuitec, IBM, Innoopract, itemis, Nokia, Oracle, 

SAP, Sonatype, Sopera

► Enterprise Members – Cisco, Motorola, BlackBerry

► Solution Members – AdaCore, Adobe, aptana, ARM, ARS, Aster Data, AvantSoft, Black Duck, BLU AGE, 

BREDEX, bsi, CAS Software, CollabNet, compeople, Compuware, Curl, DDC-I, Empolis, Engineering Group, 

Ericsson, Eteration, Excelsior, Exist Global, Express Logic, Freescale Semiconductor, froglogic, tni 

Software, Gerhardt, Google, HP, Ingres, Innovations Softwaretechnologie, Innovent Solutions, Instaniations, 

instinctools, Intalio, Intel, Intervoice, LynuxWorks, Mentor Graphics, Mind8, Modular Mind, NEC, nuxeo, OC 

Systems, Open-Xchange, OpenMake Software, Perforce, Polarion Software, Progress Software, Purple 

Scout, Puzzle ITC, QNX, red hat, Remain, Replay Solutions, Salesforce.com, Sony Ericsson, Soyatec, 

SpringSource, Sybase, Symbian,  Tasktop, teamprise, tensilica, RCP Company, TIBCO, Virutech, 

WeigleWilczek, Wind River, Xored Software, XpoLog, Zend, Zenika, ZenSar

► Associate Members - Redmond Media Group, Queue, Addison Wesley, AT& Developer Program, Atmel, 

BZ Media, Carleton University, Software Industry Center, cea list, CENIT, CWI, Communications and Media 

Arts, Generalitat Valenciana, Curl, DFKI, DSDM, DZone Network, e-Forum, EADS, Polytechnique Montreal, 

Enea, ETRI, Eurotech, FOKUS, Hitachi, IDG, Institute for Software, INRIA, Instituto Eldorado, Kybele, 

Laboratory for Safe and Secure Software, Mongo Software Labs, MB Project, Mercer, Meruvian Foundation, 

Mia-Software, MKS, Montavista, OMG, Open Source Business Foundation, Open Systems Publishing, OSGi 

Alliance, Open Source Lab, OW2, The RTC Group, Serena Software, Siemens, SIGS Datacom, Social 

Physics, Software & Support Verlag, STAR, ST, SWARM, TEI, Texas Instruments, Thales, Third Millennium 

Society, Tieto, Universidad Autonoma de Occidente, University of Agder, Programming Distributed Systems, 

University of Manchester, Vector, Vogel, VTT Technical Research Centre of Finland, Xilinx 
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► CodeWarrior on Eclipse leverages an extensible software platform made up of 
core services and interoperable plug-in components.

► Components integrate with the platform and can be extended to interoperate with 
each other. 

► The platform facilitates integration of components - both Freescale and 3rd party. 

CodeWarrior Development Studio - Eclipse Platform

3rd Party 

Service A

CodeWarrior 

Service X

CodeWarrior 

Service Y

CodeWarrior 

Service Z

3rd Party 

Service B

Eclipse-Based Development Platform 

(CodeWarrior or Strategic 3rd Party)
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CodeWarrior for Microcontrollers 10.0

Integrates the development tools for the RS08, HCS08 and ColdFire® architectures 

into a single product based on the Eclipse open development platform. 
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CodeWarrior Roadmap
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CodeWarrior Development Suite for 
Microcontrollers v10.0 Features

8
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Architectures Supported

►Use CodeWarrior Development Studio for Microcontrollers v10.0 to 

develop RS08, HCS08, and ColdFire projects

• RS08 derivatives

• HCS08 derivatives

• V1 ColdFire derivatives

• V2 ColdFire derivatives

• V3 ColdFire derivatives

• V4 ColdFire derivatives

• ColdFire evaluation boards

9
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Multiple Compilers / Single Debugger

►CodeWarrior optimizing compilers

• RS08

• HCS08

• V1-V4 ColdFire

►Debugger

• Eclipse CDT

• Extended for embedded programming 

►Profile and Trace

• HCS08 derivatives

• V1 ColdFire derivatives

10
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Use Welcome Screen for immediate access to development 

resources.

11

Welcome Screen
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New Project Wizard

12

Use New Project Wizard to create a new project in as few as 6 clicks.
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MCU Change Wizard

13

Use MCU Change Wizard to port projects to a new microcontroller in as few as 6 clicks.
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Project Importer

►Use the Project Importer to import CodeWarrior Classic 

projects
• CodeWarrior Development Studio for Microcontrollers v6.x

• CodeWarrior Development Studio for ColdFire Architectures v7.x

14
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Processor Expert

► A rapid application design tool with …

• Graphical User Interface which allows an application to be specified by the functionality 

needed

• Automatic code generator which creates tested, optimized C code tuned to the 

application needs and selected Freescale MCU

• Built-in knowledgebase, which immediately flags resource conflicts and incorrect 

settings

► Architectures supported

• RS08 derivatives

• HCS08 derivatives

• ColdFire derivatives

15
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Tutorials

16

Step by step tutorials – known as cheat sheets in Eclipse – are available for standard tasks
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Part Numbers and Pricing
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Special Editions

Standard Suite

Professional Suite

$2495
TS-$495

$4995
TS-$995

Basic Suite

$995
TS-$195

FREE

$995

$1995

$395

CodeWarrior Pricing and Packaging Model

Perpetual
Includes perpetual use of Product Suite 

plus Technical Support & Maintenance 

for 12 months
Additional years of technical support indicated 

by “TS”

Annual Subscription
Includes use of product suite plus 

Technical Support & Maintenance for 

12 months
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Basic Suite   ($995 Perpetual License / 

$395 Annual Subscription)

►CodeWarrior Development Studio for  Power Architecture, Flash 

Loader Only  (CWS-PPC-FLASH-CX)

►CodeWarrior for Power Architecture, Linux Application Edition 

(Linux hosted)  (CWS-PPC-LLAPP-CX/LX)

►CodeWarrior for Power Architecture, Linux Application Edition 

(Windows hosted)  (CWS-PPC-LINWH-CX/LX)

►CodeWarrior for ColdFire ISA, Linux Application Edition 

(Linux hosted)  (CWS-MCF-LLAPP-CX/LX)

►CodeWarrior for ColdFire ISA, Linux Application Edition 

(Windows hosted) (CWS-MCF-WLAPP-CX/LX)

►CodeWarrior for ColdFire, Compiler Upgrade Edition  

(CWS-MCF-CUPG-CX/LX)

►CodeWarrior for DSP 56800/E, Compiler Upgrade Edition  

(CWS-568-C64K-CX/LX)

►CodeWarrior for Microcontrollers v6.x, Compiler Upgrade Edition  

(CWS-H08-CUPG-CX/LX)

►CodeWarrior for Microcontrollers v10.x, Basic Edition  

(CWS-MCU-BASIC-CX/LX)

►CodeWarrior for HCS12(X), Compiler Upgrade Edition  

(CWS-H12-C64K-CX/LX)

►CodeWarrior for MobileGT, Linux Application Edition  

(Linux hosted) (CWS-MGT-LLAPP-CX/LX)

►CodeWarrior for Mobile GT Linux Application Edition

(Windows-hosted ) (CWS-MGT-WLAPP-CX/LX)

CodeWarrior Suites

Special Editions and Evaluations -

FREE 

►Special Editions

• CWX-HXX-SE

• CWX-568-SE

• CWX-MCU-SE

• CWX-MCF-SE

• CWS-MPC-5500-SE

►Evaluations

•CWX-H08-PROED-EX

•CWX-H12-PROED-EX

•CWX-MCU-PROED-EX

•CWX-MCF-PROED-EX

•CWX-MCF-LLPLT-EX

•CWX-MGT-EX

•CWX-MPC-5XX-EX

•CWX-MPC-5500B-EX

•CWX-PPC-CMWFL-EX

•CWX-PPC-LLPLT-EX

•CWX-PPC-LLAPP-EX

•CWX-PPC-LINWH-EX

•CWX-STC-WIN-EX
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CodeWarrior Suites

Standard Suite  ($2495 Perpetual License / 

$995 Annual Subscription)

►CodeWarrior for Power Architectures, Debug Only Edition  

(CWS-PPC-CMWDB-CX/LX)

►CodeWarrior for Power Architectures, Linux Platform Edition, Debug 

Only  (CWS-PPC-LLPDB-CX/LX)

►CodeWarrior for Power Architecture, Linux Application Edition

(Windows hosted)  (CWS-PPC-LINWH-CX/LX) 

►CodeWarrior for ColdFire, Standard Edition  

(CWS-MCF-STDED-CX/LX)

►CodeWarrior for ColdFire ISA, Linux Application Edition  

(Windows hosted) (CWS-MCF-WLAPP-CX/LX) 

►CodeWarrior for DSP 56800/E, Full Product  

CWS-568-CX/LX)

►CodeWarrior for Microcontrollers v6.x, Standard Edition  

(CWS-H08-STDED-CX/LX)

►CodeWarrior for Microcontrollers v10.x, Standard Edition  

(CWS-MCU-STDED-CX/LX)

►CodeWarrior for HCS12(X), Standard Edition  

(CWS-H12-STDED-CX/LX)

►CodeWarrior for Mobile GT Linux Application Edition

(Windows-hosted ) (CWS-MGT-WLAPP-CX/LX)

►CodeWarrior for MPC5XX, Debug Only Edition  

(CWS-MPC-5XXDB-CX/LX) 

Professional Suite  ($4995 Perpetual License / 

$1995 Annual Subscription)

►CodeWarrior for Power Architectures, Professional Edition  

(CWS-PPC-CMWFL-CX/LX)

►CodeWarrior for Power Architecture, Linux Application Edition

(Windows hosted)  (CWS-PPC-LINWH-CX/LX) 

►CodeWarrior for Power Architecture, Linux Platform Edition  

(CWS-PPC-LLPLT-CX/LX)

►CodeWarrior for StarCore  (CWS-STC-WIN-CX/LX)

►CodeWarrior for 68K, Full Product  (CWS-68K/FLT)

►CodeWarrior for DSP 56800/E, Full Product  (CWS-568-CX/LX)

►CodeWarrior for ColdFire, Professional Edition  

(CWS-MCF-PROED-CX/LX)

►CodeWarrior for ColdFire ISA, Linux Application Edition  

(Windows hosted) (CWS-MCF-WLAPP-CX/LX) 

►CodeWarrior for ColdFire ISA, Linux Platform Edition  

(CWS-MCF-LLPLT-CX/LX)

►CodeWarrior for Microcontrollers 6.x, Professional Edition  

(CWS-H08-PROED-CX/LX)

►CodeWarrior for Microcontrollers 10.x, Professional Edition  

(CWS-MCU-PROED-CX/LX)

►CodeWarrior for HCS12(X), Professional Edition  

(CWS-H12-PROED-CX/LX)

►CodeWarrior for MobileGT  (CWS-MGT-CX/LX)

►CodeWarrior for Mobile GT Linux Application Edition

(Windows-hosted ) (CWS-MGT-WLAPP-CX/LX) 

►CodeWarrior for MobileGT, Linux Platform Edition  

(CWS-MGT-LLPLT-CX/LX)

►CodeWarrior for MPC5XX   (CWS-MPC-5XX-CX/LX)

►CodeWarrior for MPC5500, Professional Edition  

(CWS-MPC-5500P-CX/LX)
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Suite Pricing and Part Numbers

►Professional Suite – Pro Edition

• Perpetual – $4995
 CWP-PRO-NL (node locked)  

 CWP-PRO-FL (floating)

• Annual Subscription – $1995
 CWA-PRO-NL (node locked)

 CWA-PRO-FL (floating)

• Tech Support - $995
 CWT-PRO

►Special Editions

• CWX-MCF-SE

►Standard Suite – Standard Edition

• Perpetual – $2495
 CWP-STANDARD-NL (node locked)  

 CWP-STANDARD-FL (floating)

• Annual Subscription – $995
 CWA-STANDARD-NL (node locked)

 CWA-STANDARD-FL (floating)

• Tech Support - $495
 CWT-STANDARD 

►Basic Suite – C Compiler Upgrade

• Perpetual – $995

• CWP-BASIC-NL (node locked)  

• CWP-BASIC-FL (floating)

• Annual Subscription – $395

• CWA-BASIC-NL (node locked)

• CWA-BASIC-FL (floating)

• Tech Support - $195

• CWT-BASIC
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Upgrade Policy

► Annual Subscription License

• If you have an active annual subscription license, you can download CW MCU v10.0 at no 
cost

• If your annual subscription license has expired, you must purchase another license before 
downloading CW MCU v10.0

• Basic Suite: $395

• Standard Suite: $995

• Professional Suite: $1,995

► Perpetual License

• If you purchased a perpetual license within the last 12 months, you can download CW 
MCU v10.0 at no cost

• If you have an active technical support agreement (after the first 12 months), you can 
download CW MCU v10.0 at no cost

• If your technical support agreement has expired, you must purchase another technical 
support agreement before downloading CW MCU v10.0

• Basic Suite: $195

• Standard Suite: $495

• Professional Suite: $995
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Basic Eclipse Terms
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Workbench 

►Workbench = desktop development environment

• Contains all C/C++ development-related tools.

• Shows different perspectives of the working environment.

• Main window that appears when Eclipse starts.
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Workspace

►Workspace = directory that stores the source code, files and 

settings related to your work.

• Specify the workspace on startup

• More than one project can be in a workspace

• To switch workspaces select File > Switch Workspace
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Project

►Project = container for organizing files and folders

• All C/C++ work is done in the context of projects

• CodeWarrior creates projects in new folders by default

• New files and folders can be added to a project

 File > New > File: creates a new file in project directory within the workspace 

directory

 File > New > Folder: creates a new directory in project directory within the 

workspace directory.

 Files dragged into a project are physically copied into the project directory.  

• Files outside the project folder (or outside the workspace) can be linked to a 

project

 File > New >  File > Advanced > Link to File System: creates new link in project 

directory within the workspace, which refers to a file in the file system

 File > New > Folder > Advanced > Link to File System:  creates new link to a 

directory in project folder within the workspace.  The link points to a directory in the 

user‟s file system.  Creating this link will pull the directory and all sub-components into 

the CodeWarrior project.
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View

►View = a “visual” panel in the Workbench.

• Displays information about the contents of your workbench.  

• Different views are provided for different tasks

 Problems – compile or other problems.

 Console – standard run window console.

 C/C++ Projects – view of projects in workspace.

 Breakpoints – debugging breakpoints in open projects.

• Editors are special “views” for editing files.
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Perspectives

►Perspective = collection of Eclipse views and action sets organized 

into a layout that suits an assigned task  

• Current perspective is highlighted at the top of the perspective window

• Perspectives are shown on perspective shortcut bar (top right)

• Click the perspective icon to switch among open perspectives

• To open a perspective:

 Select Window > Open Perspective > [select -or- Other]

 On the perspective view, choose Open Perspective > [select -or- Other]

• To close a perspective:

 Select Window > Close Perspective

Open Perspective Icon
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Demonstration
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Open existing project - 1

3030

Click „File‟

Select „Import…‟

Select „Existing Projects‟

Click „Next‟
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Open existing project - 2

3131

Select „Browse‟

Select a workspace folder

Click „OK‟
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Open existing project - 3

3232

Select “DEMOQE128 

_Quick_Start_S08”

Click „Finish‟
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Close project

3333

1

Select project

2 Click „Project‟

3

Select „Close Project‟
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Remove project from workspace

3434

1

Right click project

2

Click „Delete‟

3 Remove Project

Permanently delete Project

4 Click Yes‟
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Change workspace

3535

1 Click „File‟

4

Select New Workspace

2

Select „Switch 

Workspace”‟

3 Select „Other‟

5 Click „OK‟
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“CodeWarrior Projects” panel

3636

Hierarchical 

view

Alphabetical 

view

Search view

Search C file 

Input “*.c”

Search head file 

Input “*.h”
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Source Code Editor and Outline

3737

Source Code Editor Tabs Outline Tab

Lists all functions 

and definitions in 

current source file.

Move mouse over function name

Press F2 to browse details
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Configure compiler/linker/assembler - 1

3838

1

Select 

project

3

Select “Properties”

4 Click „+‟ to expand C/C++ Build

5

Select 

“Settings”

2Select “Project”
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Configure output 

format

Configure compiler/linker/assembler - 2

Click 

“Output”

6
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Configure 

optimization 

settings

Configure compiler/linker/assembler - 3

Click 

“Optimization”

7
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Open Debug Dialog

4141

1

Select project
2 Click „Run‟

3

Select „Open 

Debug Dialog…‟

4

Select “DEMOQE128_...._HCS08” Option

Select target debugger 5
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Select debugger configuration – Target MCU

4242

6
Click „Debugger‟ Tab

Select Target MCU7

Select FCS 

(simulation) or None

8
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Select debugger configuration – BDM Type

4343

9
Click 

„Connection‟ Tab Select Connection

10

Select BDM interface 11

12Click 

“Debug‟
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Debugger Perspective

4444

Debug View

Editor

Disassembly View

Console View Stack

Variables View Stack

Variables View

Console View
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Changed variables are highlighted

4545

Variables View
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To set breakpoints

4646

1
Double click in column left 

of line to set breakpoint 

2
Click „Breakpoints‟ Tab

Current breakpoints
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Enable/disable breakpoints

4747

1
Check to disable 

2
Check again to enable 
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Open Welcome Screen

4848

Welcome Screen

1Click „Help‟

2
Select „Welcome‟ 
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Open Help Menu

4949

3

Select topics

1Click „Help‟

2 Select „Cheat 

Sheets…‟

4 Click „OK‟
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Save current layout as default

5050

1. Adjust IDE 

layout

3

Select Target 

Perspective.

5. The next time CodeWarrior opens, the current 

layout will be displayed as the default.

2

Select „Save Perspective As…‟

4 Click „OK‟
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